AMH3.2 安装防CC攻击PHP脚本模块 limit_req2_nginx_module-1.2

适用版本 AMH3.1 & AMH3.2
—————————————–
模块版本名称: limit_req2_nginx_module-1.2
模块发布时间: 2013-05-26
模块描述:

nginx模块系列 – nginx限制请求处理频率的模块。典型应用:限制来自单个IP地址的请求处理频率。 限制的方法是通过一种“漏桶”的方法——固定每秒处理的请求数,推迟过多的请求处理。

模块脚本开发者:Zeraba
开发者网站:http://www.lsanday.com/
1、面板线上下载&安装:
AMH » Module » 下载模块 » 搜索 limit_req2_nginx_module-1.2 下载。
回到模块管理列表点击安装即可。
2、或使用ssh命令下载&安装:
amh module download limit_req2_nginx_module-1.2;
amh module limit_req2_nginx_module-1.2 install;
————–
目前1.0与1.1版本已下架。
在使用1.0或是1.1的用户请下载安装升级。
直接在面板搜索 limit_req2_nginx_module-1.2 下载安装,会直接升级。(旧版本会自动卸载删除)
1.2新版本更新了1.0与1.1版本存在的问题。
1) limit_req2_nginx_module1.0与1.1版本会与AMProxy-1.01不兼容。
2) 安装后主机停止后,卸载模块主机的limit_req2配置未完全移除。amh nginx restart Nginx出错。
3) 更改cc.conf 444非标准状态码为403。
其它细节,请查看开发者模块开发记录:
http://amysql.com/bbs/post-397-1-1.htm
————–
按住F5键,测试效果:

221933chi3kv3v22p03h62
221932z4a4o59v0o0154s2
附、下载limit_req2_nginx_module-1.2模块开发脚本:
http://amysql.com/file/AMH/3.2/modules/limit_req2_nginx_module-1.2.module.tar.gz

 

 

二〇一四年四月二十八日 16:24:47

点赞