Centos安装SNMP使用SNMPWALK

yum -y install net-snmp net-snmp-devel net-snmp-libs net-snmp-perl net-snmp-utils

[root@localhost ~]# yum -y install net-snmp net-snmp-devel net-snmp-libs net-snmp-perl net-snmp-utils
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.sjtu.edu.cn
* extras: mirrors.zju.edu.cn
* updates: mirror.bit.edu.cn
软件包 1:net-snmp-5.7.2-33.el7_5.2.x86_64 已安装并且是最新版本
软件包 1:net-snmp-libs-5.7.2-33.el7_5.2.x86_64 已安装并且是最新版本
软件包 1:net-snmp-utils-5.7.2-33.el7_5.2.x86_64 已安装并且是最新版本
正在解决依赖关系
--> 正在检查事务
---> 软件包 net-snmp-devel.x86_64.1.5.7.2-33.el7_5.2 将被 安装
--> 正在处理依赖关系 tcp_wrappers-devel,它被软件包 1:net-snmp-devel-5.7.2-33.el7_5.2.x86_64 需要
--> 正在处理依赖关系 rpm-devel,它被软件包 1:net-snmp-devel-5.7.2-33.el7_5.2.x86_64 需要
--> 正在处理依赖关系 perl-devel(x86-64),它被软件包 1:net-snmp-devel-5.7.2-33.el7_5.2.x86_64 需要
--> 正在处理依赖关系 openssl-devel,它被软件包 1:net-snmp-devel-5.7.2-33.el7_5.2.x86_64 需要
--> 正在处理依赖关系 lm_sensors-devel,它被软件包 1:net-snmp-devel-5.7.2-33.el7_5.2.x86_64 需要
--> 正在处理依赖关系 elfutils-libelf-devel,它被软件包 1:net-snmp-devel-5.7.2-33.el7_5.2.x86_64 需要
--> 正在处理依赖关系 elfutils-devel,它被软件包 1:net-snmp-devel-5.7.2-33.el7_5.2.x86_64 需要
---> 软件包 net-snmp-perl.x86_64.1.5.7.2-33.el7_5.2 将被 安装
--> 正在检查事务
---> 软件包 elfutils-devel.x86_64.0.0.170-4.el7 将被 安装
--> 正在处理依赖关系 pkgconfig(zlib),它被软件包 elfutils-devel-0.170-4.el7.x86_64 需要
--> 正在处理依赖关系 pkgconfig(liblzma),它被软件包 elfutils-devel-0.170-4.el7.x86_64 需要
---> 软件包 elfutils-libelf-devel.x86_64.0.0.170-4.el7 将被 安装
---> 软件包 lm_sensors-devel.x86_64.0.3.4.0-4.20160601gitf9185e5.el7 将被 安装
---> 软件包 openssl-devel.x86_64.1.1.0.2k-12.el7 将被 安装
--> 正在处理依赖关系 krb5-devel(x86-64),它被软件包 1:openssl-devel-1.0.2k-12.el7.x86_64 需要
---> 软件包 perl-devel.x86_64.4.5.16.3-292.el7 将被 安装
--> 正在处理依赖关系 systemtap-sdt-devel,它被软件包 4:perl-devel-5.16.3-292.el7.x86_64 需要
--> 正在处理依赖关系 perl(ExtUtils::ParseXS),它被软件包 4:perl-devel-5.16.3-292.el7.x86_64 需要
--> 正在处理依赖关系 perl(ExtUtils::MakeMaker),它被软件包 4:perl-devel-5.16.3-292.el7.x86_64 需要
--> 正在处理依赖关系 perl(ExtUtils::Installed),它被软件包 4:perl-devel-5.16.3-292.el7.x86_64 需要
--> 正在处理依赖关系 libdb-devel,它被软件包 4:perl-devel-5.16.3-292.el7.x86_64 需要
--> 正在处理依赖关系 gdbm-devel,它被软件包 4:perl-devel-5.16.3-292.el7.x86_64 需要
---> 软件包 rpm-devel.x86_64.0.4.11.3-32.el7 将被 安装
--> 正在处理依赖关系 popt-devel(x86-64),它被软件包 rpm-devel-4.11.3-32.el7.x86_64 需要
---> 软件包 tcp_wrappers-devel.x86_64.0.7.6-77.el7 将被 安装
--> 正在检查事务
---> 软件包 gdbm-devel.x86_64.0.1.10-8.el7 将被 安装
---> 软件包 krb5-devel.x86_64.0.1.15.1-19.el7 将被 安装
--> 正在处理依赖关系 libkadm5(x86-64) = 1.15.1-19.el7,它被软件包 krb5-devel-1.15.1-19.el7.x86_64 需要
--> 正在处理依赖关系 krb5-libs(x86-64) = 1.15.1-19.el7,它被软件包 krb5-devel-1.15.1-19.el7.x86_64 需要
--> 正在处理依赖关系 libverto-devel,它被软件包 krb5-devel-1.15.1-19.el7.x86_64 需要
--> 正在处理依赖关系 libselinux-devel,它被软件包 krb5-devel-1.15.1-19.el7.x86_64 需要
--> 正在处理依赖关系 libcom_err-devel,它被软件包 krb5-devel-1.15.1-19.el7.x86_64 需要
--> 正在处理依赖关系 keyutils-libs-devel,它被软件包 krb5-devel-1.15.1-19.el7.x86_64 需要
---> 软件包 libdb-devel.x86_64.0.5.3.21-24.el7 将被 安装
---> 软件包 perl-ExtUtils-Install.noarch.0.1.58-292.el7 将被 安装
---> 软件包 perl-ExtUtils-MakeMaker.noarch.0.6.68-3.el7 将被 安装
--> 正在处理依赖关系 perl(ExtUtils::Manifest),它被软件包 perl-ExtUtils-MakeMaker-6.68-3.el7.noarch 需要
---> 软件包 perl-ExtUtils-ParseXS.noarch.1.3.18-3.el7 将被 安装
---> 软件包 popt-devel.x86_64.0.1.13-16.el7 将被 安装
---> 软件包 systemtap-sdt-devel.x86_64.0.3.2-8.el7_5 将被 安装
--> 正在处理依赖关系 pyparsing,它被软件包 systemtap-sdt-devel-3.2-8.el7_5.x86_64 需要
---> 软件包 xz-devel.x86_64.0.5.2.2-1.el7 将被 安装
---> 软件包 zlib-devel.x86_64.0.1.2.7-17.el7 将被 安装
--> 正在检查事务
---> 软件包 keyutils-libs-devel.x86_64.0.1.5.8-3.el7 将被 安装
---> 软件包 krb5-libs.x86_64.0.1.15.1-18.el7 将被 升级
---> 软件包 krb5-libs.x86_64.0.1.15.1-19.el7 将被 更新
---> 软件包 libcom_err-devel.x86_64.0.1.42.9-12.el7_5 将被 安装
--> 正在处理依赖关系 libcom_err(x86-64) = 1.42.9-12.el7_5,它被软件包 libcom_err-devel-1.42.9-12.el7_5.x86_64 需要
---> 软件包 libkadm5.x86_64.0.1.15.1-19.el7 将被 安装
---> 软件包 libselinux-devel.x86_64.0.2.5-12.el7 将被 安装
--> 正在处理依赖关系 libsepol-devel(x86-64) >= 2.5-6,它被软件包 libselinux-devel-2.5-12.el7.x86_64 需要
--> 正在处理依赖关系 pkgconfig(libsepol),它被软件包 libselinux-devel-2.5-12.el7.x86_64 需要
--> 正在处理依赖关系 pkgconfig(libpcre),它被软件包 libselinux-devel-2.5-12.el7.x86_64 需要
---> 软件包 libverto-devel.x86_64.0.0.2.5-4.el7 将被 安装
---> 软件包 perl-ExtUtils-Manifest.noarch.0.1.61-244.el7 将被 安装
---> 软件包 pyparsing.noarch.0.1.5.6-9.el7 将被 安装
--> 正在检查事务
---> 软件包 libcom_err.x86_64.0.1.42.9-11.el7 将被 升级
--> 正在处理依赖关系 libcom_err(x86-64) = 1.42.9-11.el7,它被软件包 libss-1.42.9-11.el7.x86_64 需要
--> 正在处理依赖关系 libcom_err(x86-64) = 1.42.9-11.el7,它被软件包 e2fsprogs-libs-1.42.9-11.el7.x86_64 需要
--> 正在处理依赖关系 libcom_err(x86-64) = 1.42.9-11.el7,它被软件包 e2fsprogs-1.42.9-11.el7.x86_64 需要
---> 软件包 libcom_err.x86_64.0.1.42.9-12.el7_5 将被 更新
---> 软件包 libsepol-devel.x86_64.0.2.5-8.1.el7 将被 安装
---> 软件包 pcre-devel.x86_64.0.8.32-17.el7 将被 安装
--> 正在检查事务
---> 软件包 e2fsprogs.x86_64.0.1.42.9-11.el7 将被 升级
---> 软件包 e2fsprogs.x86_64.0.1.42.9-12.el7_5 将被 更新
---> 软件包 e2fsprogs-libs.x86_64.0.1.42.9-11.el7 将被 升级
---> 软件包 e2fsprogs-libs.x86_64.0.1.42.9-12.el7_5 将被 更新
---> 软件包 libss.x86_64.0.1.42.9-11.el7 将被 升级
---> 软件包 libss.x86_64.0.1.42.9-12.el7_5 将被 更新
--> 解决依赖关系完成

依赖关系解决

==========================================================================================================================================
Package 架构 版本 源 大小
==========================================================================================================================================
正在安装:
net-snmp-devel x86_64 1:5.7.2-33.el7_5.2 updates 250 k
net-snmp-perl x86_64 1:5.7.2-33.el7_5.2 updates 337 k
为依赖而安装:
elfutils-devel x86_64 0.170-4.el7 base 84 k
elfutils-libelf-devel x86_64 0.170-4.el7 base 38 k
gdbm-devel x86_64 1.10-8.el7 base 47 k
keyutils-libs-devel x86_64 1.5.8-3.el7 base 37 k
krb5-devel x86_64 1.15.1-19.el7 updates 269 k
libcom_err-devel x86_64 1.42.9-12.el7_5 updates 31 k
libdb-devel x86_64 5.3.21-24.el7 base 38 k
libkadm5 x86_64 1.15.1-19.el7 updates 175 k
libselinux-devel x86_64 2.5-12.el7 base 186 k
libsepol-devel x86_64 2.5-8.1.el7 base 77 k
libverto-devel x86_64 0.2.5-4.el7 base 12 k
lm_sensors-devel x86_64 3.4.0-4.20160601gitf9185e5.el7 base 26 k
openssl-devel x86_64 1:1.0.2k-12.el7 base 1.5 M
pcre-devel x86_64 8.32-17.el7 base 480 k
perl-ExtUtils-Install noarch 1.58-292.el7 base 74 k
perl-ExtUtils-MakeMaker noarch 6.68-3.el7 base 275 k
perl-ExtUtils-Manifest noarch 1.61-244.el7 base 31 k
perl-ExtUtils-ParseXS noarch 1:3.18-3.el7 base 77 k
perl-devel x86_64 4:5.16.3-292.el7 base 453 k
popt-devel x86_64 1.13-16.el7 base 22 k
pyparsing noarch 1.5.6-9.el7 base 94 k
rpm-devel x86_64 4.11.3-32.el7 base 106 k
systemtap-sdt-devel x86_64 3.2-8.el7_5 updates 73 k
tcp_wrappers-devel x86_64 7.6-77.el7 base 17 k
xz-devel x86_64 5.2.2-1.el7 base 46 k
zlib-devel x86_64 1.2.7-17.el7 base 50 k
为依赖而更新:
e2fsprogs x86_64 1.42.9-12.el7_5 updates 699 k
e2fsprogs-libs x86_64 1.42.9-12.el7_5 updates 167 k
krb5-libs x86_64 1.15.1-19.el7 updates 747 k
libcom_err x86_64 1.42.9-12.el7_5 updates 41 k
libss x86_64 1.42.9-12.el7_5 updates 45 k

事务概要
==========================================================================================================================================
安装 2 软件包 (+26 依赖软件包)
升级 ( 5 依赖软件包)

总下载量:6.5 M
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
(1/33): elfutils-libelf-devel-0.170-4.el7.x86_64.rpm | 38 kB 00:00:01
(2/33): gdbm-devel-1.10-8.el7.x86_64.rpm | 47 kB 00:00:01
(3/33): elfutils-devel-0.170-4.el7.x86_64.rpm | 84 kB 00:00:01
(4/33): keyutils-libs-devel-1.5.8-3.el7.x86_64.rpm | 37 kB 00:00:00
(5/33): libcom_err-1.42.9-12.el7_5.x86_64.rpm | 41 kB 00:00:00
(6/33): krb5-devel-1.15.1-19.el7.x86_64.rpm | 269 kB 00:00:01
(7/33): krb5-libs-1.15.1-19.el7.x86_64.rpm | 747 kB 00:00:01
(8/33): libdb-devel-5.3.21-24.el7.x86_64.rpm | 38 kB 00:00:00
(9/33): e2fsprogs-1.42.9-12.el7_5.x86_64.rpm | 699 kB 00:00:04
(10/33): libkadm5-1.15.1-19.el7.x86_64.rpm | 175 kB 00:00:01
(11/33): libsepol-devel-2.5-8.1.el7.x86_64.rpm | 77 kB 00:00:00
(12/33): libselinux-devel-2.5-12.el7.x86_64.rpm | 186 kB 00:00:00
(13/33): libcom_err-devel-1.42.9-12.el7_5.x86_64.rpm | 31 kB 00:00:01
(14/33): libss-1.42.9-12.el7_5.x86_64.rpm | 45 kB 00:00:00
(15/33): libverto-devel-0.2.5-4.el7.x86_64.rpm | 12 kB 00:00:00
(16/33): lm_sensors-devel-3.4.0-4.20160601gitf9185e5.el7.x86_64.rpm | 26 kB 00:00:00
(17/33): net-snmp-devel-5.7.2-33.el7_5.2.x86_64.rpm | 250 kB 00:00:01
(18/33): e2fsprogs-libs-1.42.9-12.el7_5.x86_64.rpm | 167 kB 00:00:07
(19/33): perl-ExtUtils-Install-1.58-292.el7.noarch.rpm | 74 kB 00:00:00
(20/33): perl-ExtUtils-Manifest-1.61-244.el7.noarch.rpm | 31 kB 00:00:00
(21/33): perl-ExtUtils-MakeMaker-6.68-3.el7.noarch.rpm | 275 kB 00:00:01
(22/33): perl-ExtUtils-ParseXS-3.18-3.el7.noarch.rpm | 77 kB 00:00:00
(23/33): perl-devel-5.16.3-292.el7.x86_64.rpm | 453 kB 00:00:01
(24/33): popt-devel-1.13-16.el7.x86_64.rpm | 22 kB 00:00:00
(25/33): pcre-devel-8.32-17.el7.x86_64.rpm | 480 kB 00:00:03
(26/33): systemtap-sdt-devel-3.2-8.el7_5.x86_64.rpm | 73 kB 00:00:00
(27/33): rpm-devel-4.11.3-32.el7.x86_64.rpm | 106 kB 00:00:00
(28/33): tcp_wrappers-devel-7.6-77.el7.x86_64.rpm | 17 kB 00:00:00
(29/33): xz-devel-5.2.2-1.el7.x86_64.rpm | 46 kB 00:00:00
(30/33): net-snmp-perl-5.7.2-33.el7_5.2.x86_64.rpm | 337 kB 00:00:06
(31/33): zlib-devel-1.2.7-17.el7.x86_64.rpm | 50 kB 00:00:00
(32/33): pyparsing-1.5.6-9.el7.noarch.rpm | 94 kB 00:00:04
(33/33): openssl-devel-1.0.2k-12.el7.x86_64.rpm | 1.5 MB 00:00:16
------------------------------------------------------------------------------------------------------------------------------------------
总计 297 kB/s | 6.5 MB 00:00:22
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
正在更新 : libcom_err-1.42.9-12.el7_5.x86_64 1/38
正在安装 : zlib-devel-1.2.7-17.el7.x86_64 2/38
正在安装 : elfutils-libelf-devel-0.170-4.el7.x86_64 3/38
正在更新 : krb5-libs-1.15.1-19.el7.x86_64 4/38
正在安装 : libkadm5-1.15.1-19.el7.x86_64 5/38
正在更新 : libss-1.42.9-12.el7_5.x86_64 6/38
正在安装 : libcom_err-devel-1.42.9-12.el7_5.x86_64 7/38
正在更新 : e2fsprogs-libs-1.42.9-12.el7_5.x86_64 8/38
正在安装 : tcp_wrappers-devel-7.6-77.el7.x86_64 9/38
正在安装 : lm_sensors-devel-3.4.0-4.20160601gitf9185e5.el7.x86_64 10/38
正在安装 : libsepol-devel-2.5-8.1.el7.x86_64 11/38
正在安装 : xz-devel-5.2.2-1.el7.x86_64 12/38
正在安装 : elfutils-devel-0.170-4.el7.x86_64 13/38
正在安装 : popt-devel-1.13-16.el7.x86_64 14/38
正在安装 : rpm-devel-4.11.3-32.el7.x86_64 15/38
正在安装 : libverto-devel-0.2.5-4.el7.x86_64 16/38
正在安装 : gdbm-devel-1.10-8.el7.x86_64 17/38
正在安装 : pyparsing-1.5.6-9.el7.noarch 18/38
正在安装 : systemtap-sdt-devel-3.2-8.el7_5.x86_64 19/38
正在安装 : pcre-devel-8.32-17.el7.x86_64 20/38
正在安装 : libselinux-devel-2.5-12.el7.x86_64 21/38
正在安装 : perl-ExtUtils-Manifest-1.61-244.el7.noarch 22/38
正在安装 : libdb-devel-5.3.21-24.el7.x86_64 23/38
正在安装 : 1:perl-ExtUtils-ParseXS-3.18-3.el7.noarch 24/38
正在安装 : perl-ExtUtils-MakeMaker-6.68-3.el7.noarch 25/38
正在安装 : perl-ExtUtils-Install-1.58-292.el7.noarch 26/38
正在安装 : 4:perl-devel-5.16.3-292.el7.x86_64 27/38
正在安装 : keyutils-libs-devel-1.5.8-3.el7.x86_64 28/38
正在安装 : krb5-devel-1.15.1-19.el7.x86_64 29/38
正在安装 : 1:openssl-devel-1.0.2k-12.el7.x86_64 30/38
正在安装 : 1:net-snmp-devel-5.7.2-33.el7_5.2.x86_64 31/38
正在更新 : e2fsprogs-1.42.9-12.el7_5.x86_64 32/38
正在安装 : 1:net-snmp-perl-5.7.2-33.el7_5.2.x86_64 33/38
清理 : e2fsprogs-1.42.9-11.el7.x86_64 34/38
清理 : e2fsprogs-libs-1.42.9-11.el7.x86_64 35/38
清理 : libss-1.42.9-11.el7.x86_64 36/38
清理 : krb5-libs-1.15.1-18.el7.x86_64 37/38
清理 : libcom_err-1.42.9-11.el7.x86_64 38/38
验证中 : krb5-devel-1.15.1-19.el7.x86_64 1/38
验证中 : zlib-devel-1.2.7-17.el7.x86_64 2/38
验证中 : keyutils-libs-devel-1.5.8-3.el7.x86_64 3/38
验证中 : libdb-devel-5.3.21-24.el7.x86_64 4/38
验证中 : perl-ExtUtils-Manifest-1.61-244.el7.noarch 5/38
验证中 : pcre-devel-8.32-17.el7.x86_64 6/38
验证中 : 1:perl-ExtUtils-ParseXS-3.18-3.el7.noarch 7/38
验证中 : pyparsing-1.5.6-9.el7.noarch 8/38
验证中 : gdbm-devel-1.10-8.el7.x86_64 9/38
验证中 : perl-ExtUtils-MakeMaker-6.68-3.el7.noarch 10/38
验证中 : 1:openssl-devel-1.0.2k-12.el7.x86_64 11/38
验证中 : libverto-devel-0.2.5-4.el7.x86_64 12/38
验证中 : popt-devel-1.13-16.el7.x86_64 13/38
验证中 : libselinux-devel-2.5-12.el7.x86_64 14/38
验证中 : libss-1.42.9-12.el7_5.x86_64 15/38
验证中 : 4:perl-devel-5.16.3-292.el7.x86_64 16/38
验证中 : libcom_err-devel-1.42.9-12.el7_5.x86_64 17/38
验证中 : e2fsprogs-libs-1.42.9-12.el7_5.x86_64 18/38
验证中 : elfutils-libelf-devel-0.170-4.el7.x86_64 19/38
验证中 : e2fsprogs-1.42.9-12.el7_5.x86_64 20/38
验证中 : 1:net-snmp-perl-5.7.2-33.el7_5.2.x86_64 21/38
验证中 : libkadm5-1.15.1-19.el7.x86_64 22/38
验证中 : elfutils-devel-0.170-4.el7.x86_64 23/38
验证中 : rpm-devel-4.11.3-32.el7.x86_64 24/38
验证中 : xz-devel-5.2.2-1.el7.x86_64 25/38
验证中 : libsepol-devel-2.5-8.1.el7.x86_64 26/38
验证中 : krb5-libs-1.15.1-19.el7.x86_64 27/38
验证中 : libcom_err-1.42.9-12.el7_5.x86_64 28/38
验证中 : perl-ExtUtils-Install-1.58-292.el7.noarch 29/38
验证中 : systemtap-sdt-devel-3.2-8.el7_5.x86_64 30/38
验证中 : 1:net-snmp-devel-5.7.2-33.el7_5.2.x86_64 31/38
验证中 : lm_sensors-devel-3.4.0-4.20160601gitf9185e5.el7.x86_64 32/38
验证中 : tcp_wrappers-devel-7.6-77.el7.x86_64 33/38
验证中 : libcom_err-1.42.9-11.el7.x86_64 34/38
验证中 : libss-1.42.9-11.el7.x86_64 35/38
验证中 : krb5-libs-1.15.1-18.el7.x86_64 36/38
验证中 : e2fsprogs-libs-1.42.9-11.el7.x86_64 37/38
验证中 : e2fsprogs-1.42.9-11.el7.x86_64 38/38

已安装:
net-snmp-devel.x86_64 1:5.7.2-33.el7_5.2 net-snmp-perl.x86_64 1:5.7.2-33.el7_5.2

作为依赖被安装:
elfutils-devel.x86_64 0:0.170-4.el7 elfutils-libelf-devel.x86_64 0:0.170-4.el7
gdbm-devel.x86_64 0:1.10-8.el7 keyutils-libs-devel.x86_64 0:1.5.8-3.el7
krb5-devel.x86_64 0:1.15.1-19.el7 libcom_err-devel.x86_64 0:1.42.9-12.el7_5
libdb-devel.x86_64 0:5.3.21-24.el7 libkadm5.x86_64 0:1.15.1-19.el7
libselinux-devel.x86_64 0:2.5-12.el7 libsepol-devel.x86_64 0:2.5-8.1.el7
libverto-devel.x86_64 0:0.2.5-4.el7 lm_sensors-devel.x86_64 0:3.4.0-4.20160601gitf9185e5.el7
openssl-devel.x86_64 1:1.0.2k-12.el7 pcre-devel.x86_64 0:8.32-17.el7
perl-ExtUtils-Install.noarch 0:1.58-292.el7 perl-ExtUtils-MakeMaker.noarch 0:6.68-3.el7
perl-ExtUtils-Manifest.noarch 0:1.61-244.el7 perl-ExtUtils-ParseXS.noarch 1:3.18-3.el7
perl-devel.x86_64 4:5.16.3-292.el7 popt-devel.x86_64 0:1.13-16.el7
pyparsing.noarch 0:1.5.6-9.el7 rpm-devel.x86_64 0:4.11.3-32.el7
systemtap-sdt-devel.x86_64 0:3.2-8.el7_5 tcp_wrappers-devel.x86_64 0:7.6-77.el7
xz-devel.x86_64 0:5.2.2-1.el7 zlib-devel.x86_64 0:1.2.7-17.el7

作为依赖被升级:
e2fsprogs.x86_64 0:1.42.9-12.el7_5 e2fsprogs-libs.x86_64 0:1.42.9-12.el7_5 krb5-libs.x86_64 0:1.15.1-19.el7
libcom_err.x86_64 0:1.42.9-12.el7_5 libss.x86_64 0:1.42.9-12.el7_5

完毕!
点赞